Disturbance in service
Incident Report for nShift - Delivery and TMS
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 12:41 CEST
Update
We are continuing to investigate this issue.
Posted Aug 29, 2023 - 12:40 CEST
Investigating
We are currently experiencing disturbances in our service. We are investigating and will give you an update as soon as possible.
Posted Aug 29, 2023 - 12:33 CEST
This incident affected: Unifaun Online /nShift Delivery and Posti Smartship.