Unable to find pickup agent for Bring PickUp Parcel Bulk and Bring PickUp Parcel
Incident Report for nShift - Delivery and TMS
Resolved
This incident has now been resolved.
Posted Feb 28, 2023 - 09:48 CET
Investigating
We are currently investigating the issue
Posted Feb 28, 2023 - 09:17 CET
This incident affected: Unifaun Online /nShift Delivery.