Support can not be reached by phone
Incident Report for nShift - Delivery and TMS
Resolved
This incident has been resolved.
Posted May 04, 2021 - 12:53 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 11:24 CEST
Identified
At the moment Unifaun support can not be reached by phone, due to an incident at our supplier. Please contact us via email.
Posted May 04, 2021 - 10:36 CEST